Missing tracking updates of Swiss Post Shipments

Incident Report for Seven Senders

Resolved

To maintain the tracking quality, we are using a different source of tracking until the carrier fixes the issue.
Posted Apr 15, 2025 - 16:27 CEST

Identified

Swiss Post has confirmed that they detected problems with the generation of reports and are working hard to fix them.
Posted Apr 15, 2025 - 07:02 CEST

Investigating

We are not receiving tracking updates from Swiss Post. Our team is in contact with the carrier.
We are actively working on resolving the issue with the highest priority.
Posted Apr 14, 2025 - 16:13 CEST
This incident affected: Tracking (Tracking, Shop SQS).