Shipping labels partially unavailable due to service suppliers

Incident Report for Seven Senders

Monitoring

Since 16:30, we have not observed any missing label requests related to the issue described. We will continue to monitor the situation closely.
Posted Nov 18, 2025 - 17:43 CET

Identified

It has been reported that Cloudflare has identified the root cause of the issue and is working to restore services.
Posted Nov 18, 2025 - 15:09 CET

Investigating

You may experience intermittent errors when attempting to generate labels due to an upstream issue with Cloudflare. We are working closely with our partners to restore full stability immediately. We sincerely apologize for the interruption.
Posted Nov 18, 2025 - 13:47 CET
This incident affects: Label Service - General.