Partial Outage: Delays in DPD PL Label Requests

Incident Report for Seven Senders

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 10:40 CET

Investigating

We are currently experiencing slow response times from DPD for the carrier DPD PL, causing partial outages when requesting DPD PL labels. We have already reached out to the carrier and will provide an update as soon as the issue is fully resolved.
On behalf of the carrier, we sincerely apologize for any inconvenience caused and appreciate your patience.
Posted Mar 17, 2025 - 10:14 CET