Missing tracking updates of SEUR Shipments

Incident Report for Seven Senders

Resolved

This incident has been resolved.
Posted May 15, 2025 - 16:38 CEST

Investigating

We are not receiving tracking updates from Seur. Our team is in contact with the carrier.
We are actively working on resolving the issue with the highest priority.
Posted May 15, 2025 - 15:46 CEST
This incident affected: Tracking (Tracking, Shop SQS).