Post NL Maintenance: Potential performance impact between June 2, 09:00 - 10:00AM (CEST)

Scheduled for Jun 2, 09:00 - 10:00 CEST

Update

We will be undergoing scheduled maintenance during this time.
Posted May 08, 2026 - 13:15 CEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Jun 02, 2026 - 09:00 CEST

Scheduled

Please be informed that the carrier Post NL will perform system maintenance during the following time:

--> Start: 02.06.2026 - 09:00 (CEST)
--> End: 02.06.2026 - 10:00 (CEST)

During this period, you may experience occasional interruptions or degraded performance.

This announcement is only relevant for customers:
1. Using the 7S label service for the creation of Post NL Labels or
2. Customers who are directly connected with the Post NL Label creation, tracking and shipping status APIs.

On behalf of Post NL, we apologize for any inconvenience this may cause.
Posted Jun 02, 2026 - 09:00 CEST
This scheduled maintenance affects: Label Service - Carrier APIs (POST NL).